Study Visa checks (not standard work rights or MARA Agent checks) remain offline

Incident Report for vSure Status Page

Resolved

Study Visa checks are now working
Posted Feb 22, 2026 - 21:02 AEDT

Monitoring

It appears Work Rights and MARA agent checks are back online, but Study Visa checks remains impacted by the Home Affairs weekend long maintenance.
Posted Feb 22, 2026 - 20:56 AEDT
This incident affected: APIs (API v2, API v1).